Some customers are unable to downgrade their account
Incident Report for Pusher
Resolved
This incident has been resolved.
Posted Nov 01, 2024 - 15:58 UTC
Investigating
We are aware of an issue where customers can't downgrade their account plan. Everything else continues to function normally.
Posted Nov 01, 2024 - 15:32 UTC
This incident affected: Channels Dashboard.