Dashboard stats incomplete
Incident Report for Pusher
Resolved
We have made changes to our storage layer, and having monitored for over a week since the changes, we are happy that the underlying issue has been resolved.
Posted Dec 12, 2016 - 10:21 UTC
Monitoring
Data is moving correctly through to the dashboard again, though we are not satisfied that we have addressed the root cause yet.

Unfortunately the data for the period 2016-11-17 15:00 - 16:05 UTC was lost. This may result in historic daily totals appearing short of the actual values, while limits are still being enforced based on accurate data.

We continue to work to address the underlying performance problems which have prevented the timely presentation of data.
Posted Nov 17, 2016 - 18:26 UTC
Investigating
The dashboard historic stats are suffering another backend failure. We are extremely frustrated by this turn of events and are working to make improvements. However, it seems likely that the historic stats pages will not receive new data for at least the next 24 hours.

The data is still being collected, but it not making it to the presentation layer.

Limits are still being enforced based on accurate data.

Real-time stats showing usage during the last 30 minutes remain available on the account and app overview pages, so you should not be in the dark about the current behaviour of your Pusher apps.

We apologise for this interruption to service.
Posted Nov 16, 2016 - 18:00 UTC