Interruption in Stats Collection and Degraded Datadog Integration

Incident Report for Pusher

Resolved

The backlog has fully cleared and Stats Collection and Datadog integration are now operating normally.

This incident is now resolved. We apologise for any inconvenience caused and appreciate your patience throughout.
Posted Apr 10, 2025 - 09:59 UTC

Monitoring

Systems are now catching up on the backlog, and Realtime Stats and Datadog integration should gradually return to normal. We are continuing to monitor the recovery closely and will provide another update once the catch-up is fully complete.
Posted Apr 10, 2025 - 07:27 UTC

Identified

The issue affecting Stats Collection and the Datadog integration has been identified and addressed.

Systems are now catching up on the backlog, and Realtime Stats and Datadog integration should gradually return to normal. We are continuing to monitor the recovery closely and will provide another update once the catch-up is fully complete.

Thank you for your continued patience.
Posted Apr 09, 2025 - 14:37 UTC

Investigating

We are currently experiencing an issue affecting our stats collection systems.

As a result, Realtime Stats are currently unavailable. Additionally, our Datadog integration is experiencing degraded performance.

Our engineering team is actively investigating the root cause and working to restore normal service as quickly as possible. We will provide updates as we learn more.

Thank you for your patience and understanding.
Posted Apr 09, 2025 - 08:10 UTC
This incident affected: Channels Dashboard and Channels Stats Integrations.