We are experiencing a major outage in our US2 cluster
Incident Report for Pusher
Resolved
This incident has been resolved.
Posted Sep 08, 2024 - 23:06 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 08, 2024 - 23:05 UTC
Update
A fix has been implemented, and we are monitoring the results. WebSocket connections should now be functional.
Posted Sep 08, 2024 - 22:21 UTC
Monitoring
The team has been able to identify the issue and push a fix. We are seeing a full recovery of the services. We will continue to monitor.
Posted Sep 08, 2024 - 22:19 UTC
Update
Our team is still investigating the issue within our infrastructure that is preventing us from adding WebSocket capacity to the US2 cluster. This issue is specifically impacting our WebSocket deployments.
The majority of clients are currently unable to connect using WebSocket. However fallback mechanisms (SockJS, HTTP streaming, and HTTP polling) are available for connection if they are not disabled in your configuration.
Posted Sep 08, 2024 - 21:19 UTC
Update
We are escalating the current issue from a partial outage to a major outage. The majority of traffic in the US2 cluster is currently affected. Our team is fully engaged and working to resolve the issue.
Posted Sep 08, 2024 - 19:31 UTC
Investigating
We are investigating what is causing the issue to our US cluster.
Posted Sep 08, 2024 - 18:00 UTC
This incident affected: Channels REST API, Channels WebSocket client API, Channels presence channels, and Channels Webhooks.