Issues with Google Auth login on dash.pusher.com
Incident Report for Pusher
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 27, 2019 - 13:51 UTC
Investigating
Issue preventing some users logging in to dash.pusher.com with Google Auth. Other login methods remain available.
Posted about 2 months ago. Jun 27, 2019 - 13:31 UTC