MT1 cluster - increased latency

Incident Report for Pusher

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:14 UTC

Investigating

Our cloud provider is currently experiencing an incident that's causing increased latency on Pusher Channels main cluster `mt1` . This issue is external to our systems and is not related to our infrastructure. Our team is actively investigating to determine if there are any additional impacts and working to minimize downstream effects while our provider implements a fix.
Posted Oct 20, 2025 - 17:26 UTC
This incident affected: Channels REST API, Channels WebSocket client API, Channels Dashboard, and Channels presence channels.