AP1 cluster - Socket connection failures

Incident Report for Pusher

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 13:34 UTC

Update

All services are now fully operational. We continue to monitor the cluster.
Posted Oct 27, 2025 - 12:53 UTC

Monitoring

We observed unusual activity on the cluster, likely caused by at least one customer experiencing a cyber attack. Our team is mitigating the issue while simultaneously increasing cluster resources to minimize impact on other customers. The cluster availability is returning to normal. We continue to monitor closely.
Posted Oct 27, 2025 - 12:41 UTC

Identified

A fix is implemented. We are seeing improvements and continue to actively monitor the situation to ensure full stability. During the incident, many clients successfully connected using fallback protocols.
Posted Oct 27, 2025 - 12:22 UTC

Investigating

We are currently experiencing disruptions with socket connections in AP1 cluster, which began at 10:00 UTC. Clients may experience reconnections. Our team is actively investigating the issue and working to restore full connectivity as quickly as possible.
Posted Oct 27, 2025 - 11:50 UTC
This incident affected: Channels WebSocket client API and Channels presence channels.