Pusher.com website down

Incident Report for Pusher

Resolved

This incident has been resolved.
Posted Apr 02, 2024 - 07:09 UTC

Investigating

We are currently investigating this issue.
Posted Apr 02, 2024 - 06:12 UTC
This incident affected: Marketing Website.